Howspace (in.howspace.com) logo

Incident

Websocket connection issue

Closed | Jun 08, 2023 | 12:00 GMT+03:00

The issue has been resolved and closed.

The Websocket connection issues started when our updated Websocket authentication process closed some connections ungracefully. This triggered a flood of retry attempts from the disconnected clients, which overloaded our servers and propagated the problem to other connections.

We apologize for any inconvenience it might have caused and thank you for your patience and understanding.

Affected components

  • Howspace (in.howspace.com)

Resolved | Jun 01, 2023 | 16:00 GMT+03:00

The Websocket connection issues started when our updated Websocket authentication process closed some connections ungracefully. This triggered a flood of retry attempts from the disconnected clients, which overloaded our servers and propagated the problem to other connections.

We are pleased to inform you that our development team swiftly identified and resolved the issue. We are actively working to prevent similar challenges from occurring in the future. We apologize for any inconvenience caused and appreciate your patience during this time.

Monitoring | Jun 01, 2023 | 14:15 GMT+03:00

The websocket connection issue has now been fixed. We are still monitoring the situation and analyzing the root cause behind the issue.

Resolution in progress | Jun 01, 2023 | 13:48 GMT+03:00

We are deploying an update to production that will hopefully resolve the connection issue.

Open | Jun 01, 2023 | 13:10 GMT+03:00

There is currently an issue with the Websocket connection. We are investigating the reason behind the issue and are working on resolving it as soon as possible.

Status Page powered by Admin Labs